Comcast Hair Pulling

Comcast Internet access is driving me crazy because their “simple set-up” has been anything but thus far. I went to pick up the modem and other stuff from a nearby office yesterday and spent over an hour there as they tried to figure out my order from the call center (it seems that the call center left a message that I was going to come and pick up the modem, but failed to input that I would actually be receiving the service. On top of that, they said I still had an old modem which had been returned over a year ago. Fun stuff.

That finally all got worked out and now I’m in the process of actually trying to get the service set up. Their easy to install software has not been working correctly (at least for me) so I will be calling their help center to see if I can get this all set up today.

While I have been pulling my hair a bit during the process, I keep reminding myself that at least I’m not in Japan where the situation would probably be even worse. Hopefully this will be settled today and I’ll be up and running on a good connection so I can get back to business.

Update: woohoo! Finally got through all the issues after a couple of calls to Comcast and I’m finally up and running. Such a stress relief not to have page response issues while on the Internet. Now to try and catch up on a week’s worth of backlog…

This entry was posted in Miscellaneous. Bookmark the permalink.

3 Responses to Comcast Hair Pulling

  1. Steve Mertz says:

    I feel your pain-those simple/easy instlalls are never as advertised! Good Luck :)

  2. pfadvice says:

    I’d hate to see what a difficult install would be like 😉

  3. Jimmy Stephens says:

    We continue to put up with bad service like Comcast because we don’t want government regulation. I trust the US Government a lot more than I trust Wall Street.

Leave a Reply

Your email address will not be published. Required fields are marked *